Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
1.6 install issues.
  • I'm trying to install 1.6 on a site that had 1.5
    I'm running into issues.

    First, curl | sh'  was initially giving me 'Oil doesnt understand and is confused' error.
    I removed oil from the system and still get the same error

    I tried downloading the 1.6 file and was going to upload the contents, but there is no composer.json file in there. (Am I misunderstanding this?)

    Are there any updated docs on the 1.6 install coming from 1.5?
    I am at a loss at this point.


  • First issue is solved.

    We were still running on Pagodabox on Phil's account, and we had to move that in a hurry. During the move the wrong script was placed on the new server. It should now correctly install the oil script.

    I've just downloaded the zip from the website, in it is a fuelphp-1.6 folder, and in there the entire fuel installation, including the required composer files. What exactly did you download?

    The procedure for upgrading an existing installation depends a bit on how you installed in the first place, and is documented here:

    Don't forget to read the changelog, especially important if you come from 1.5, don't forget to remove the Log package and the entry for this package in always_load!
  • I'm attempting to update to 1.6 but am unable to install Composer.  When running the command, I'm getting a 503 Service Unavailable from  the FuelPHP Upload repo.
  • Hmmm... That's odd, it shouldn't go to the repo, it should download it from packagist.

    How did you update your base install? Also the oil and index.php has been updated, did you update those too? What's in your composer.json? What is installed in /fuel/vendor ?

  • I install FuelPHP and I run the command

    php composer.phar update

    Then it install "fuelphp/upload" and want to install "monolog/monolog" but crash because I don't have git installed on my computer...
    I don't want to install git, and I can't for right raison (enterprise rules)

    If "fuelphp/upload" and "monolog/monolog" are required, why you don't put it in zip package ?

    How to install monolog by hand ?

    I try to put files in "vendor/monolog/monolog" but it does'nt work and a "php composer.phar update" delete the folder "vendor/monolog/monolog"
  • I backed up my current installation and simply uploaded all the files from the 1.6 build overwriting any old ones.  I did update oil and index.php and the link below shows what's in composer.json

    EDIT: fuel/vendor is empty except for a .gitkeep file
  • Ok, so it doesn't break on upload, it breaks on Monolog? It should get the packagist zip for that as well.

    In the composer.json file, can you change the monolog version to "1.4.*" and run Composer update again?
  • Everything seems to work now.  I ran into the same issue as gportail, but your suggestion seemed to fix it.
  • Weird.

    I'll check with Jordi (the Composer author) to see why it (sometimes?) decides to do a git checkout, even if the package is on packagist, and there is a valid reference to a zipped version...
  • The 'curl | sh' is now working for me.

    Are my user config setting sstill supposed to be in the /fuel/app/config dir?

    I used the core config and placed it in my /fule/app/config dir and getting errors.
    I'm getting :

    ErrorException [ Error ]: Uncaught exception
    'Fuel\Core\PhpErrorException' with message
    'include(/home/mySite/wwwroot/fuel/core/classes/config/php.php) [function.include]: failed to open stream: No such file or directory' in /home/mySite/wwwroot/fuel/core/classes/autoloader.php:

    Weird thing is it was working and then when I copied the config into the fuel dir, it blows up like this. I renamed the dir to something else and it still fails.

    Any ideas?

  • Deleted everything again and will try again,.

    I did review the files downloaded the other night and they did not include OIL or any of the other files associated with composer and such as the archive that I just downloaded now.

  • Yes, application config goes in app/config, and you only need to add the values for which you want to override the defaults, the core will fill in the rest.

    There is no php.php in fuel/core, nor should there be. A "no sush file" is usually a rights issue.

    What exactly did you download? The download zip on the website is absolutely complete, but does not contain the libraries you need to install through composer, as you need to run composer yourself to install the dependencies.
  • Best practice question: what is the recommended placement for including extra composer packages in 1.6?
  • I still have the zip file that downloaded the other night. It does not contain the oil file and a few other files.

    As for this one with the missing 'config' dir and the 'no such file' /php.php issue.
    I downloaded the zip again today and ended up manually uploading all the files. I ran into a weird error that the checksum or key could not be validated, but that was because I had uploaded the .phar as ascii instead of binary. once I reuploaded the .phar file as binary, the refine install and update to composer worked fine.

    I am having a weird thing now.
    If i enter in, I get and the 'Bloody Hell'

    I'm thinking I may have everything in place at the moment, but we'll see.

    Thanks for the followups.
  • @BigTone,

    Just add the required packages to the existing composer.json, and don't worry about location.
  • @maxarbos,

    Weird. I've only created one zip file, that I've uploaded to the website. I keep all copies locally, and I've just check, and it does contain all required files. You're sure you're looking at

    Did you create any htaccess or other rewrite rules manually? Did you configure any weird base_url in your config?
  • Install FuelPHP with "monolog/monolog": "1.4.*", in composer.json work for me !!.
    The command "php composer.phar update" downoload monolog and I get default web page.

    Thanks !!
  • 'Did you create any htaccess or other rewrite rules manually? Did you configure any weird base_url in your config?'

    No, not that I see.
    I didnt add anything to the htaccess file. I also checked the vhosts file and nothing set in there either.
    I tried commented out the 'Remove index.php' from the htaccess again, but that didnt make any different either.

  • Hello,

    There is an incompatibility between the latest auth users table definition and the Auth->create_user() function if you are using Simpleauth driver.
    In 1.6 migration file you are creating a "group_id" field both for Simpleauth and Ormauth.
    But in the create_user() function of fuel/packages/auth/classes/auth/login/simpleauth.php you are still refering to 'group' field (line 234).

  • Very well spotted, I'll fix that.

    Fixed pushed to the 1.7/develop repository.
  • Hi,

    I'm using git and would appreciate more information on how to upgrade from 1.5 to 1.6

    As a basic git user I'm stuck in the middle of the process and failing upgrading properly to 1.6 so my project is still 1.5

    I did a git pull at the root of the project followed by a git submodule update

    Remote upstream is fuel/fuel across the project so the first git pull fetched everything including for packages (orm, etc.)

  • If you're using git, you can just pull in upstream 1.6/master (or 1.7/develop) of the fuel/fuel repo, which will update your local installation. After that you can update the submodules, and Fuel itself is up to date. This process hasn't changed at all.

    What has is that 1.6 introduces Composer.

    After the pull, you should now have a composer.phar and a composer.json in the root of your application installation. On the commandline, run "php composer.phar update" to install the composer dependencies.
  • As I'm far from being a git guru, I tried the following

    git pull origin/1.6/master

    But got 
    fatal: 'origin/1.6/master' does not appear to be a git repository
    fatal: Could not read from remote repository.

    When running a git branch -r I can see origin/1.6/master in the list, so I thing I'm doing something wrong when trying to pull from the git remote repository. Git doc is quite obscure to me. Where can I find a "how-to" ? 
  • If your origin is still set to github's fuel/fuel repository, you have a bit of an issue with regards to the changes you've made locally. a simple pull will work within the branch you're currently working in, but you can't switch branches.

    In your installation root, create a new branch for your local changes, for example "master", and make that current:

    git branch master
    git checkout master

    Now you have a local branch that doesn't exist remote that you can work from. Next step is to merge the remote changes from 1.6 in:

    git pull origin 1.6/master

    this might create conflicts that you may have to fix. Once fixed, do a commit of the changes to your local master branch, update git submodules, and run composer to pull the external dependencies in.

  • OK I see.
    It created conflicts I'm dealing with now. But things are on better tracks.
  • Usually the conflicts are minimal, there isn't a lot of code in the fuel/fuel repo.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion