Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
v1.6 install problems (composer not installed)
  • I'm having trouble installing FuelPHP v1.6.

    I'm using the 'manual install' method, I believe I've followed all steps correctly. I downloaded v1.6 from the FuelPHP home page, extracted, and uploaded to my (LAMP) web server. It's a fresh install, not an upgrade from a previous version.

    When I run 'php composer.phar update', it returns instantly with no output. Is this expected?

    When I try to access the site, it reports "Composer is not installed. Please run "php composer.phar update" in the root to install Composer". The same message is generated from 'php oil refine install', of course.

    Following another suggestion, I tried changing the required monolog version in composer.json to 1.4, but it made no difference.

    Is there any thing I can do to debug what is going on?

    Thanks, Chris
  • On a local test setup, I can see what the output from the 'php composer.phar update' command should look like - more or less.

    Running it on the test setup, I first got an error
    • [RuntimeException] Failed to clone via git, https and http protocols, aborting ((git reported "fatal: remote error: Storage server temporarily offline"))
    I tried changing the monolog version to 1.4, and then got an error 
    Any ideas as to how to get past these problems?

    I still have no idea why 'php composer.phar update' silently fails on the web server - is there any debug I can use?

    Thanks, Chris
  • It pulls from github, and they've been having issues all day, I can't update some repositories as well.

    You can try running composer with "--prefer-dist", which will try to find zipfiles instead of cloning git repositories...
  • Thanks for the advice, Harro - today everything is working fine in my test environment which now has FuelPHP fully installed (with monolog 1.5).

    Have you any suggestions what I could do about 'php composer.phar update' failing silently on the web server? (it comes back with a shell prompt immediately without any output). I can only guess a missing or misplaced file, but I've no idea how to investigate... any suggestions?

    Thanks, Chris
  • HarroHarro
    Accepted Answer
    I don't know, I've never seen that before.

    Perhaps this gives some pointers?
  • Harro, you are a hero as always.

    From that troubleshooting link, I found that the curl -sS | php -- --check command told me:

    Some settings on your machine make Composer unable to work properly.
    Make sure that you fix the issues listed below and run this script again:

    The suhosin.executor.include.whitelist setting is incorrect.
    Add the following to the end of your `php.ini` or suhosin.ini (Example path [for Debian]: /etc/php5/cli/conf.d/suhosin.ini):
        suhosin.executor.include.whitelist = phar 

    The php.ini used by your command-line PHP is: /etc/php5/cli/php.ini
    If you can not modify the ini file, you can also run `php -d option=value` to modify ini values on the fly. You can use -d multiple times.

    Up and running now.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion