Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
Logs permissions problem on debian
  • Hello i have problem with my installation.

    If i type "oil refine install" it receives error:

    Error - Uncaught exception 'Fuel\Core\FuelException' with message 'Unable to create or write to the log file. Please check the permissions on /var/www/fuel/fuel/app/logs/' in /var/www/fuel/fuel/core/classes/log.php:77
    Stack trace:
    #0 [internal function]: Fuel\Core\Log::_init()
    #1 /var/www/fuel/fuel/core/classes/autoloader.php(364): call_user_func('Log::_init')
    #2 /var/www/fuel/fuel/core/classes/autoloader.php(247): Fuel\Core\Autoloader::init_class('Log')
    #3 [internal function]: Fuel\Core\Autoloader::load('Log')
    #4 /var/www/fuel/fuel/core/base.php(91): spl_autoload_call('Log')
    #5 /var/www/fuel/fuel/core/classes/error.php(117): logger(400, 'Notice - date_d...')
    #6 /var/www/fuel/fuel/core/bootstrap.php(71): Fuel\Core\Error::exception_handler(Object(Fuel\Core\PhpErrorException))
    #7 [internal function]: {closure}(Object(Fuel\Core\PhpErrorException))
    #8 {main}
      thrown in COREPATH/classes/log.php on line 77

    i set chmod 0777 for logs and it's still not working.
    Help :)

  • Problem is that this exception "hides" the original error.

    Go into fuel/core/classes/log.php, and before the "throw" on line 77 add:

    var_dump($e->getMessage()); die();

    which will give you the error that caused the exception.

    We need to fix this...
  • Okay, I fixed it :) There was a problem with date.timezone =]

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion