Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
Can't config file uploading
  • Hi. I have successfully installed and configured fuelPHP. But now I can't use upload class as described at http://fuelphp.com/docs/classes/upload/usage.html#/usage_example
    I got an error "Class 'FuelPHP\Upload\Upload' not found"
    COREPATH/classes/upload.php @ line 90
    static::$upload = new \FuelPHP\Upload\Upload($config);

    I tried to install fuelphp/upload using composer.phar with no effect.
    Can somebody helps?
  • What do you mean "no effect"?

    /data/www/fuelphp/1.7/develop (1.7/develop)
    [hverton@catwoman] $ php composer.phar update
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    - Installing monolog/monolog (1.5.0)
    Loading from cache

    - Installing fuelphp/upload (2.0)
    Loading from cache

    monolog/monolog suggests installing mlehner/gelf-php
    monolog/monolog suggests installing raven/raven
    monolog/monolog suggests installing doctrine/couchdb
    monolog/monolog suggests installing ext-amqp
    monolog/monolog suggests installing ext-mongo
    Generating autoload files
    /data/www/fuelphp/1.7/develop (1.7/develop)
    [hverton@catwoman] $

  • Thank you. I found the solution myself.

    1) ./composer.phar self-update
    2) ./composer.phar update
    3) ./composer.phar require fuelphp/upload
    when it asked for version I typed "1.*" 
    Now it works fine with fuelphp/upload v 1.7

    Versions "2.0" and "dev-master" generates error described above.
  • Harro VertonHarro Verton
    Accepted Answer
    You didn't mention the version you're using.

    To be complete, for FuelPHP 1.6 you need Upload "1.*", for FuelPHP 1.7 you need "2.0".
  • I am sorry. I thought stable release is a default.
  • Yes, it is.

    But there are lots of people running the latest develop, or not the latest release version. So sometimes it's difficult to give the correct answer, as solutions differ from version to version.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion