Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
issues with using latest Opauth
  • Hi,

    I'm getting below error when updating my opauth and strategy to latest version. 

    Auth\OpauthException [ Error ]:
    Opauth composer package not installed. Add "opauth/opauth" to composer.json and run a composer update.

    Here is my composer.json

        "require": {
            "php": ">=5.3.3",
            "monolog/monolog": "1.5.*",
            "opauth/opauth": "1.0.*@dev",
            "opauth/facebook": "1.0.*@dev",
        "fuelphp/upload": "2.0.1"
        },

    any idea


  • Harro VertonHarro Verton
    Accepted Answer
    See https://github.com/opauth/opauth/tree/1.0:

    "1.0.x is currently under preview release and not to be used for production yet. See release notes for details. Opauth API and functionalities are fully ready for evaluation. Please try it out and let us know what you think.

    1.0.x is not backward-compatible with 0.x. See migration guide on how to migrate Opauth 0.x applications and strategies."

    Since it's not backward compatible, it's also not compatible with Fuel's Opauth driver.

  • Fast answer as always! Thanks Harro.

    If any changes under the "Vendor" package, do we need to change the core/package code as well?
  • I haven't had a look at the changes, but since they say "not backward compatible" it means the Fuel code will need to change.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion