Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
Blank White Page after extracting the zip file
  • Hi.., 
    I used to develop FuelPHP in windows with Xampp and now I'm trying to install FuelPHP for the first time in linux server with cpanel. I don't have the access to shell so try to install from downloaded zip file.

    . as a trial, I try to upload (new download) the zip file and then put it in public_html/test and hoping can access the website in www.***.com/test/public. BUt I only found a Blank white page.., 

    I read the requirements and compare it to my remote server and it says:
    PHP version5.4.30
    MySQL version5.5.37-cll
    Apache version2.2.27
    cPanel Version11.44.1 (build 18)

    I guess it's fine.., and then I try to change permission for app/chache app/logs app/tmp and app/config to 777.

    is there some step that I missed???

    tQ for your help
  • FuelPHP is designed so that all code is outside the webservers document root. With low-buget hosting, this can only be achieved by renaming the public folder to public_html, and FTP the installation to the file root of your hosting server.

    Installing it inside the document root like you do is not a problem, but obviously requires you to type the full path to the index.php location.

    By default, error messages are enabled, so www.***.com/test/public/index.php should either give you the welcome screen, or some sort of PHP error message. Have you checked your webservers log file, to see if something is logged there?
  • Accessing www.***.com/test/public/index.php still give me a blank white page.

    I've checked the error log and it says:
    [Mon Sep 15 15:52:23 2014] [error] [client xx.xx.xx.xx] ] [notice] EACCELERATOR(9986): PHP crashed on opline 58 of register_shutdown_function() at /home/***/public_html/test/fuel/core/bootstrap.php:78
  • Ah, EAccelerator.

    That's a piece of antique, and should not be running anymore. You should be able to disable it through cPanel?

    If you can't, you can try disabling it through the .htacess in the public folder, by adding

    php_admin_value eaccelerator.enable 0
  • I don't understand how to disable eacceletaror from cpanel, because there is no option in disabling it. I search in google how to disable eaccelerator from cpanel and found nothing.
    so I try to add php_admin_value eaccelerator.enable 0 to .httaccess is public folder as you say..,
    but now log error says

    [Tue Sep 16 09:49:43 2014] [alert] [client] /home/***/public_html/test/public/.htaccess: Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration

    here the .htaccess

    # Multiple Environment config, set this to development, staging or production
    # SetEnv FUEL_ENV production

    php_admin_value EACCELERATOR.enable 0
    RewriteEngine on

    # NOTICE: If you get a 404 play with combinations of the following commented out lines
    #AllowOverride All
    #RewriteBase /wherever/fuel/is

  • HarroHarro
    Accepted Answer
    Ok, so your hoster doesn't allow you to change settings from htaccess.

    Then you have a problem, the only options left are report the problem to your hoster and hope they will fix it, or change hosters, because this one seems to be crap (nobody uses eaccelerator anymore). Or have him upgrade to PHP 5.5, which has an excellent internal opcache system.
  • tQ for the advice..
    I'll suggest the hoster to upgrade to PHP 5.5..,
  • HarroHarro
    Accepted Answer
    And remove eaccelerator... ;-)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion