Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
Is FuelPHP compatible with PHP 7.2?
  • Hi,

    I have recently upgraded my php version to php 7.2 and I am getting a this exception:
    "Fuel\Core\PhpErrorException [ Warning ]:
    get_class() expects parameter 1 to be object, null given"

    Can i run my fuelphp apps with php 7.2 or i need to downgrade to 7.1? A lot of new linux distros comes with 7.2.

    Thanks
  • Switch to the 1.9/dev branch.

    Afaik these issues are fixed, but not pushed to the master branch yet.

    We develop our Fuel apps on (currently) 7.3.6, without any issues (I've heared of ;-)).
  • Fuel 1.8.2 has been released, which is compatible with PHP 7.3.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion