Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
Fixed bugs "Fuel requires Sodium support in PHP. Either use PHP 7.2+ ... paragonie.php on 33
  • Hi all, 
    I using fulephp 1.8.2 but my php version is 7.0, if you use session, log show erros as: 

    "Fuel requires Sodium support in PHP. Either use PHP 7.2+, install the libsodium PECL extension, of the sodium-compat composer package! in fuel\core\vendor\paragonie.php on 33"

    To resolve this problem: 
    1. Composer update 
     -  First: In directory : fuel/core/composer.json, update this line: "paragonie/sodium_compat": "1.9.4",
    - Then you run: php composer.phar update
    2. Edit file crypt.php
     - Go to path: fuel/core/classes/crypth.php 
     - Edit file: add line before "import('paragonie.php', 'vendor');" as below
    import('paragonie/sodium_compat/autoload.php', 'vendor');
    import('paragonie.php', 'vendor');
  • Update to 1.9-dev. Still haven't gotten around to tagging it with a 1.8.x release.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion