Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
fuel/core is not being pushed to GIT repository
  • Hi guys, I've created a new project using oil (performed
    curl | sh
    earlier) and added another remote. After I've pushed it and cloned it on a different machine I noticed that fuel/core was empty. After several tries I still cannot get fuel/core being pushed to the remote repository. If you level into that folder in the original repo (not the cloned one) I saw that git isn't using any branch - you have to manually switch into master branch. Any hints for me? Thanks in advance,
  • I had that same issue a little while ago. Figured I did something wrong with setting the project up.
  • And do you still know what it was? I mean I did the normal way:
    1. oil create <project_name>
    2. git remote rename origin fuel
    3. git remote add origin ssh://user@remoterepo.tld/project_name.git
    4. git push origin master All but fuel/core is being pushed.
  • I have no idea what caused it. I ended up just removing the submodules and created a new local git project which kept all of the files. Not the best solution since I can't update from github anymore.
  • Yeah, thats they key. I also wanna update from github. Hopefully s.o. else has a subtle solution. Thanks anyway.
  • I always cd to directory I want to start working with fuel, and just do: git clone --recursive git:// .
    it clones whole repo with submodules etc. so I can start up working with it If I wanted ie to update core, I do:
    cd fuel/core; and run git pull to update the repo I always update fuel packages/fore separately later
  • Hi huglester, that sounds like a suitable solution for now! UPDATE: seems that "oil create project_name" does the same like you. In the end I get the same issue unfortunately. Thanks for that.
  • I tried to re-read first post.. then I don't fully get what you trying to achieve.
    once you downloaded the fuel, and core is it's place you can start working with it. use oil etc... Oil won't create any other code dir's or smth like that
  • Hi, ok, lets start from zero. If I download fuel manually from github everything is fine. I can add all files to a new git repository and push it to my local git-server. But: if I use "oil create project_name" oil creates a new local repository on my machine and clones current fuel repo into it - with all submodules. If I now try to add another remote (my local git-server) and push it to it, fuel/core somehow gets excluded. I'm no native speaker but I tried to write it as clear as possible. Thanks, Bastian
  • ok, after you push to your git server, and you try and clone it back to a new machine, are you using the --recursive option to retrieve the submodules also?
  • After cloning, do this: git pull origin master --recurse-submodules && git submodule update --init --recursive This will update the indices of your submodules and pull them (and any submodules they contain).

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion