Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
mod_rewrite and rewritebase with port 8080
  • HI am new here and I have been trying to get rid of the public/index.php for a couple of hours now, I have read a lot of topics here in the forum to try to resolve it, but I can't get mine to work. First I want to say that I used to use Codeignter and I was able to get rid of the index.php when I had wamp installed, however I had to install visual studio and I don't know what happen when it installed IIS , if it took over port 80 but I could not use wamp anymore, so I had to download bitnami wampstack which gave me the option to choose whatever port I wanted , I chose port 8080. I already checked like 5 times and I have mod_write enabled, removed the index.php from config. I have folder in the root directory htdocs named fuel so htdocs/fuel which is where I put my project. Here is my .htaccess file . I have tried putting /fuel/public , making the base url to [url=http://localhost:8080/fuel/]http://localhost:8080/fuel/[/url] and many other things and I can't get this to work. So the only thing I can think of is the fact that I am using port 8080, this really wouldn't be a problem for me but when I use scaffoding it sucks for me to put the public/index.php just to add some fields. So any help will be appreciated.
  • If Fuel is installed in the 'fuel' folder of your docroot, you'll need
    RewriteBase /fuel/public

    as the index.php is in the public directory.
    If that doesn't work, try something like
    RewriteRule ^(.*)$ %{HTTP_HOST}:%{SERVER_PORT}/index.php/$1 [L]

    and enable your rewrite log (with level 9) to see what actually happens.
  • I am sorry but where exactly do I put rewrite log and how do I enable it, inside the htaccess? all I found was something like this online Also I found this in a tutorial but I don't know what he meant with /home/phil/sites/blog/public all I did was replace the <VirtualHost> with VirtualHost *:8080
  • Rewritelog and Rewritelevel are (afaik) not supported in .htaccess, you need to put it in your virtualhost definition. I'll see if I can find the time tomorrow to replicate your situation...

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion