Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
github error
  • hi, When trying the create command I get following error:
    [*****@ns1 public_html]$ oil create blogging
    Cloning into ./blogging...
    fatal: unable to connect to[0:]: errno=No route to host Could not open input file: ./blogging/oil

    I tried contacting github for this but this was their answer:
    From: Petros Amiridis (GitHub Staff)
    Subject: [Contact] linux github error I am afraid you will have to ask FuelPHP, what they are trying to clone and what are the prerequisites. Unless the error is network related on your end.

    So I hope you guys can help me on this.
  • "No route to host" when the host does resolve is either a network connectivity issue, or a security issue. Oil does a clone using the git protocol, which might be blocked by a firewall at your end. Can you clone manually using the git commandline? Does it work when you switch to http?
  • I'm not quite sure how I would need to clone manually... But about the blocking, what might be blocked? is it a port? is it something which can be enabled by me? or only by the host...
    What do you mean by : Does it work when you switch to http?
  • the oil installer uses the git commandline tool to download the repository. By default, it uses the git protocol (if you open the script, you'll see it uses "git clone --recursive git://". The default for the git protocol is TCP port 9418. I don't know your work environment, but I work in lots of locations where outgoing connections on that port are blocked by a firewall. What I meant was to try "git clone --recursive" instead. This uses standard http, which works in most cases, also because it supports http proxies. So basically, if you can browse to github, you can access the repo's over http.
  • IT WORKED!!!!! finally ^^ thanks, it was the port that was blocked.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion