Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
Problems updating to 1.2
  • Hi Guys, I created my Fuel app using the oil installation tool, so it is essentially a collection of submodules, which is brilliant. Unfortunately, i'm not clear on how to upgrade my app to 1.2 - i've tried `git submodule update --init` but i have a feeling that because i'm keeping the base folder in my own git repository, it's not picking up the fact that fuel has new commits available. Secondly, i tried to `cd` into all the submodules and update their branches manually to `1.2/master` for each one, this seemed to work, and i set about removing all the deprecated and removed code from the changelog, however, when i came to clone this repo on another machine and run `oil refine migrate` to install the DB, it kept giving the error: Error: end() expects parameter 1 to be array, integer given in /Users/dan/Sites/simply-fuel/fuel/core/classes/migrate.php on 104 Running `oil -v` returns that Fuel is indeed v1.2, and i can see the updates to the classes in core, but this migration problem is a killer for me. I tried migrating all the way down with `--version=0` and then back up, i also tried removing the tables from the DB manually, but i still got the same error. Any help you can give about something i might have missed is happily received. Thanks,
  • As an addendum to this, is there anything outside the submodules that need replacing?
  • Hi, Oil doesn't provide a method to update the install automatically. You'll have to download the latest version and move your app stuff over. As of 2.0 it'll be done using composer, making it way easier to update. So for now manual is the way to go. I know it's somehow possible with git, but this is wayyyy easier.
  • Okay then, i understand that Oil isn't an update utility - just wondered if there was a quicker way than manually, if there isn't, then that's fine! :) Would the best bet be to Replace everything except fuel/app and public/assets then? Thankyou, by the way!
  • Hmm, i've just tried updating manually and the same error occurs, giving me this error when trying to migrate stuff: Warning - end() expects parameter 1 to be array, integer given in COREPATH/classes/migrate.php on line 104 Are there any changes i need to make to my migrations from 1.1 to 1.2 in order for them to run? For reference, what i did was: Took a blank, working fuelphp instance. Copied my fuel/app folder over from the old app.
    Copied my other packages over from the old app (leaving the email/orm/auth ones intact)
    Copied my assets folder over from the old app. From the browser, this appears to be running fine, but migrations aren't working.
  • Turns out the migration problems were caused by an incorrect function name in one of the migrations (16/28). All fixed, thankyou again guys.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion