Love Fuel?    Donate

FuelPHP Forums

Ask your question about FuelPHP in the appropriate forum, or help others by answering their questions.
Problems on MAMP following oil introduction screencast
  • I've searched around a bit for this and have done my googling. Today is my first day playing around with FuelPHP. I'm trying to follow along with this: #1 Ive installed FuelPHP properly, and also changed my localhost to as opposed to localhost because i read that would cause problems. I ran the command php oil generate without any trouble. I then tried to do php oil refine migrate but my terminal basically times out and doesn't move on. Disclaimer: I don't have a lot of experience with the terminal. I also have no tables created when i check PHPmyAdmin possible reasons for error: I did try to do this when I was having errors before switching to >> sudo ln -s /Applications/MAMP/Library/bin/mysql /usr/bin/mysql
    >> sudo ln -s /Applications/MAMP/tmp/mysql/mysql.sock /var/mysql/mysql.sock from this post: so I guess im concerned i may have sudo'd something improperly? and because of my lack of terminal experience I dont know if this could potentially be the cause of my problems or not.
  • I get this error now: when I php oil r migrate. Presumably because i didnt have any tables inserted when I ran generate. 1046 - No database selected [ CREATE TABLE IF NOT EXISTS `migration` (
    `name` varchar(50) NOT NULL,
    `type` varchar(25) NOT NULL,
    `version` int(11) DEFAULT '0' NOT NULL
    ) DEFAULT CHARACTER SET utf8; ] in COREPATH/classes/database/mysql/connection.php on line 210
  • ah... success- I changed mysql back to pdo in the main config and changed my development db config back to localhost instead of

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion